SSL Certification errors
Incident Report for Sherpany
Resolved
This incident has been resolved.
Posted Sep 11, 2021 - 19:02 CEST
Investigating
We are currently investigating this issue.
Posted Sep 11, 2021 - 18:45 CEST
This incident affected: Sherpany Application.